Sunday, September 8, 2013

TinyMCE problem with IE9

This is just a simple post about one of the problems I had while using tinyMCE editor in Internet Explorer.
The issue was actually in the versions above IE8 only, i.e. IE9 and IE10. May be there some compatibility issues between tinyMCE editor and Internet Explorer.
Suppose there is a form having a textarea with tinyMCE controls added to it and a submit button. The form uses post method. When you submit this form with a value in the textarea, then that value is not posted to the action of the form(in IE9, IE10; for other browsers, it works fine). That means, the value of the textarea with tinyMCE controls is not transferred through HTTP POST method in versions above IE8.
So, unless the issuse is fixed in tinyMCE editor or Internet Explorer, we can force the Internet Explorer to behave as its older version.
The simplest thing is to just include this line in your html document(where you are using textarea with tinyMCE controls) after the starting of the head tag.
<head>
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

That's it. Well, there are many solutions available for this issue but I think it is the simplest one.

2 comments:

  1. "Well, there are many solutions available for this issue"
    Could you list some of the other solutions please, as adding an emulation header is not something I can do on our site.

    ReplyDelete
    Replies
    1. Well, this was the solution that worked for me. On web, there are many threads available discussing this problem and trying to suggest some solutions. "So, unless the issuse is fixed in tinyMCE editor or Internet Explorer, we can force the Internet Explorer to behave as its older version".

      Delete